Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.4

CVE-2024-8364: WordPress WP Custom Fields Search plugin allows malicious scripts to run

CVE-2024-8364 · published 2 years ago
Summary

The WP Custom Fields Search plugin for WordPress has a security flaw that allows attackers with contributor-level access or higher to inject malicious code into pages. This code can run whenever a user visits those pages, potentially allowing the attacker to take control of the site or steal user data. To fix this, update the plugin to version 1.2.36 or later.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
webhammer wp_custom_fields_search <= 1.2.35
cpe:2.3:a:webhammer:wp_custom_fields_search:*:*:*:*:*:wordpress:*:*
Original advisory text
The WP Custom Fields Search plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's wpcfs-preset shortcode in all versions up to, and including, 1.2.35 due to insufficien...
The WP Custom Fields Search plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's wpcfs-preset shortcode in all versions up to, and including, 1.2.35 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
5.4 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published19 Sep 2024
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-8364 · NVD
Track software like this
Free during beta