Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.4
CVE-2024-8123: WP Extended plugin allows attackers to copy protected posts
CVE-2024-8123 · published 2 years ago
Summary
A security issue in the WP Extended plugin for WordPress allows attackers with contributor-level access to copy posts written by other authors, including administrators. This could potentially expose password-protected posts. WordPress users should update the WP Extended plugin to the latest version to fix this issue.
What to do
- Update wpextended wp_extended to version 3.0.9 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| wpextended | wp_extended |
< 3.0.9 cpe:2.3:a:wpextended:wp_extended:*:*:*:*:*:wordpress:*:* |
Original advisory text
The The Ultimate WordPress Toolkit – WP Extended plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 3.0.8 via the duplicate_post function d...
The The Ultimate WordPress Toolkit – WP Extended plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 3.0.8 via the duplicate_post function due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Contributor-level access and above, to duplicate posts written by other authors including admins. This includes the ability to duplicate password-protected posts, which reveals their contents.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-639Authorization Bypass Through User-Controlled Key
Timeline
Published4 Sep 2024
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-8123 · NVD
Track software like this
Free during beta