Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
2.0
CVE-2024-8011: Logitech Options+ on MacOS allows local attacks via library injection
CVE-2024-8011 · published 2 years ago
Summary
Logitech Options+ on MacOS versions prior to 1.72 is vulnerable to a local attack that can allow an attacker to take control of the application's permissions, potentially granting them access to sensitive features like the camera. This means that if an attacker gains access to your device, they may be able to use your camera without your knowledge or consent. To fix this, update to the latest version of Logitech Options+ (version 1.72 or later) to ensure your device is secure.
What to do
- Update logitech options\+ to version 1.72 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| logitech | options\+ |
< 1.72 cpe:2.3:a:logitech:options\+:*:*:*:*:*:macos:*:* |
Original advisory text
Logitech Options+ on MacOS prior 1.72 allows a local attacker to inject dynamic library within Options+ runtime and abuse permissions granted by the user to Options+ such as Camera.
Logitech Options+ on MacOS prior 1.72 allows a local attacker to inject dynamic library within Options+ runtime and abuse permissions granted by the user to Options+ such as Camera.
References
- https://www.hackerone.com Not Applicable
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-863Incorrect Authorization
Timeline
Published25 Aug 2024
Updated26 Oct 2026
First seen7 Mar 2026
Sources
CVE-2024-8011 · NVD
Track software like this
Free during beta