Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.8
CVE-2024-6850: Carousel Slider plugin: High-privilege users can inject malicious code
CVE-2024-6850 · published 2 years ago
Summary
The Carousel Slider plugin for WordPress is vulnerable to a security threat. This means that users with high-level permissions, like editors, could potentially inject malicious code into your website, even if WordPress's security settings are set to block it. To fix this, update the plugin to version 2.2.4 or later.
What to do
- Update majeedraza carousel_slider to version 2.2.14 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| majeedraza | carousel_slider |
< 2.2.14 cpe:2.3:a:majeedraza:carousel_slider:*:*:*:*:*:wordpress:*:* |
Original advisory text
The Carousel Slider WordPress plugin before 2.2.4 does not sanitise and escape some of its settings, which could allow high privilege users such as editors to perform Cross-Site Scripting attacks e...
The Carousel Slider WordPress plugin before 2.2.4 does not sanitise and escape some of its settings, which could allow high privilege users such as editors to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
References
- https://wpscan.com/vulnerability/c06995cb-1685-4751-811f-aead52a597a7/ Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published13 Sep 2024
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-6850 · NVD
Track software like this
Free during beta