Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.8
CVE-2024-6700: Pega Platform: Malicious Code Can Run in Browser
CVE-2024-6700 · published 2 years ago
Summary
Pega Platform versions 8.1 to 24.1.2 have a security weakness that allows a hacker to inject malicious code into a web page, potentially stealing user data or taking control of the user's account. This means that users of affected systems may be at risk of having their sensitive information compromised. Update to version 24.1.3 or later to fix this issue.
What to do
- Update pega infinity to version 24.1.3 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| pega | infinity |
>= 8.1, < 24.1.3 cpe:2.3:a:pega:infinity:*:*:*:*:*:*:*:* |
Original advisory text
Pega Platform versions 8.1 to Infinity 24.1.2 are affected by an XSS issue with App name.
Pega Platform versions 8.1 to Infinity 24.1.2 are affected by an XSS issue with App name.
References
- https://support.pega.com/support-doc/pega-security-advisory-c24-vulnerability-re... Permissions Required
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published12 Sep 2024
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-6700 · NVD
Track software like this
Free during beta