Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.4
CVE-2024-50501: Kata Plus lets attackers run code in visitors' browsers
CVE-2024-50501 · published 2 years ago
Summary
The Kata Plus plugin (versions up to 1.4.7) does not properly clean user-supplied data when generating web pages, allowing malicious scripts to run in a visitor’s browser. This can let attackers steal information or manipulate the site’s appearance. Update to a patched version or apply proper input sanitization to eliminate the risk.
What to do
- Update climaxthemes kata_plus to version 1.5.0 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| climaxthemes | kata_plus |
< 1.5.0 cpe:2.3:a:climaxthemes:kata_plus:*:*:*:*:*:wordpress:*:* |
Original advisory text
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Climax Themes Kata Plus kata-plus allows DOM-Based XSS.This issue affects Kata Plus: from n/a t...
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Climax Themes Kata Plus kata-plus allows DOM-Based XSS.This issue affects Kata Plus: from n/a through <= 1.4.7.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published28 Oct 2024
Updated3 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-50501 · NVD
Track software like this
Free during beta