Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.8
CVE-2024-50411: WP Abstracts plugin can let attackers add harmful code
CVE-2024-50411 · published 2 years ago
Summary
The WP Abstracts plugin (versions up to 2.7.1) does not properly clean the data that is saved and later shown on web pages. An attacker could store malicious script code that runs in the browsers of anyone viewing the affected pages, potentially stealing information or altering the page content. Update the plugin to the latest version or remove it if no longer needed, and ensure any custom content is reviewed for unexpected code.
What to do
- Update kevonadonis wp_abstracts to version 2.7.2 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| kevonadonis | wp_abstracts |
< 2.7.2 cpe:2.3:a:kevonadonis:wp_abstracts:*:*:*:*:*:wordpress:*:* |
Original advisory text
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kevon Adonis WP Abstracts wp-abstracts-manuscripts-manager allows Stored XSS.This issue affects...
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kevon Adonis WP Abstracts wp-abstracts-manuscripts-manager allows Stored XSS.This issue affects WP Abstracts: from n/a through <= 2.7.1.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published29 Oct 2024
Updated3 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-50411 · NVD
Track software like this
Free during beta