Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.1

CVE-2024-4869: The WP Cookie Consent ( for GDPR, CCPA & ePrivacy ) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘Client-IP’ header in all versions up to, and including, 3.2.0 due to i...

CVE-2024-4869 · published 2 years ago
Summary

The WP Cookie Consent ( for GDPR, CCPA & ePrivacy ) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘Client-IP’ header in all versions up to, and including, 3.2.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attacker...

What to do
  • Update wpeka wp_cookie_consent to version 3.3.0 or later.
Affected software
VendorProductAffected versions
wpeka wp_cookie_consent < 3.3.0
cpe:2.3:a:wpeka:wp_cookie_consent:*:*:*:*:-:wordpress:*:*
Original advisory text
The WP Cookie Consent ( for GDPR, CCPA & ePrivacy ) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘Client-IP’ header in all versions up to, and including, 3.2.0 due to i...
The WP Cookie Consent ( for GDPR, CCPA & ePrivacy ) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘Client-IP’ header in all versions up to, and including, 3.2.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
6.1 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published26 Jun 2024
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2024-4869 · NVD
Track software like this
Free during beta