Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.3

CVE-2024-47617: Sulu CMS allows attackers to inject malicious code through media links

CVE-2024-47617 · published 2 years ago
Summary

An attacker can inject malicious code into Sulu CMS by manipulating media download links, potentially stealing sensitive information, manipulating website content, or taking control of a user's account. This issue has been fixed in versions 2.6.5 and 2.5.21. Make sure to update your Sulu CMS to one of these patched versions to prevent this risk.

What to do
  • Update sulu sulu to version 2.6.5.
  • Update sulu sulu to version 2.5.21.
Affected software
Ecosystem VendorProductAffected versions
composer sulu sulu >= 2.6.0, <= 2.6.4
>= 2.0.0, <= 2.5.20
Fix: upgrade to 2.6.5
– sulu sulu 2.5.20
2.6.4
cpe:2.3:a:sulu:sulu:2.5.20:*:*:*:*:*:*:*
Original advisory text
Reflected XSS Vulnerability in Sulu Media Bundle
Sulu is a PHP content management system. This vulnerability allows an attacker to inject arbitrary HTML/JavaScript code through the media download URL in Sulu CMS. It affects the SuluMediaBundle component. The vulnerability is a Reflected Cross-Site Scripting (XSS) issue, which could potentially allow attackers to steal sensitive information, manipulate the website's content, or perform actions on behalf of the victim. This vulnerability is fixed in 2.6.5 and 2.5.21.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
5.3 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published3 Oct 2024
Updated4 Nov 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta