Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2024-47378: wpcom_member plugin lets attackers run scripts in browsers
CVE-2024-47378 · published 2 years ago
Summary
The wpcom_member plugin for WordPress, up to version 1.5.4, fails to properly clean data that appears on web pages. An attacker can craft a link that injects malicious code, which runs in a visitor's browser and could steal information or hijack the session. Update the plugin to the latest release or disable it until a fix is applied.
What to do
- Update wpcom wpcom_member to version 1.5.4.1 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| wpcom | wpcom_member |
< 1.5.4.1 cpe:2.3:a:wpcom:wpcom_member:*:*:*:*:*:wordpress:*:* |
Original advisory text
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Lomu WPCOM Member wpcom-member allows Reflected XSS.This issue affects WPCOM Member: from n/a t...
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Lomu WPCOM Member wpcom-member allows Reflected XSS.This issue affects WPCOM Member: from n/a through <= 1.5.4.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published5 Oct 2024
Updated31 Oct 2026
First seen7 Mar 2026
Sources
CVE-2024-47378 · NVD
Track software like this
Free during beta