Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2024-47317: Ads by WPQuads allows unauthorized changes up to version 2.0.84
CVE-2024-47317 · published 2 years ago
Summary
The Ads by WPQuads plugin (versions up to 2.0.84) does not properly check who is allowed to change its settings. This means an attacker could alter ad content or placement without permission, potentially showing unwanted or malicious ads to visitors. Update the plugin to the latest release or apply the vendor's patch to restore proper access controls.
What to do
- Update wpquads ads to version 2.0.85 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| wpquads | ads |
< 2.0.85 cpe:2.3:a:wpquads:ads:*:*:*:*:*:wordpress:*:* |
Original advisory text
Missing Authorization vulnerability in Ads by WPQuads Ads by WPQuads quick-adsense-reloaded.This issue affects Ads by WPQuads: from n/a through <= 2.0.84.
Missing Authorization vulnerability in Ads by WPQuads Ads by WPQuads quick-adsense-reloaded.This issue affects Ads by WPQuads: from n/a through <= 2.0.84.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-862Missing Authorization
Timeline
Published1 Nov 2024
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-47317 · NVD
Track software like this
Free during beta