Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.6

CVE-2024-47090: Nagvis editor can run malicious scripts in browser

CVE-2024-47090 · published 1 year ago
Summary

The Nagvis monitoring tool’s built-in text editor does not properly clean user input. This can let an attacker insert code that runs in a visitor’s web browser, potentially stealing data or hijacking sessions. Update Nagvis to version 1.9.47 or later, or apply the vendor’s patch.

What to do
  • Update debian nagvis to version 1:1.9.47-1.
  • Update nagvis nagvis to version 1.9.47 or later.
Affected software
Ecosystem VendorProductAffected versions
– nagvis nagvis < 1.9.47
cpe:2.3:a:nagvis:nagvis:*:*:*:*:*:*:*:*
Ubuntu:16.04:LTS canonical nagvis All versions
Debian:12 debian nagvis All versions
Debian:13 debian nagvis < 1:1.9.47-1
Fix: upgrade to 1:1.9.47-1
Original advisory text
XSS via WYSIWYG editor
Improper neutralization of input in Nagvis before version 1.9.47 which can lead to XSS
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
7.6 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published27 May 2025
Updated4 Nov 2026
First seen7 Mar 2026
Track software like this
Free during beta