Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.9
CVE-2024-43805: Jupyter Notebook and JupyterLab allow malicious notebooks to steal data
CVE-2024-43805 · published 2 years ago
Summary
If a user opens a specially crafted notebook or markdown file in JupyterLab or Jupyter Notebook, an attacker can view any files or make web requests that the user can access. Updating to the latest versions of JupyterLab (v3.6.9 or later, v4.2.6 or later) and Jupyter Notebook (v7.2.3 or later) fixes the problem. If you cannot upgrade immediately, you can reduce the risk by disabling the mathjax and markdown preview extensions, though this will remove equation and markdown preview features.
What to do
- Update jupyter development team notebook to version 7.2.2.
- Update jupyter development team jupyterlab to version 3.6.8.
- Update jupyter development team jupyterlab to version 4.2.5.
- Update jupyter-notebook to version 7.2.2.
- Update jupyterlab to version 4.2.5.
- Update debian jupyterlab to version 4.0.11+ds1+~cs11.25.27-3.
- Update jupyter notebook to version 7.2.2 or later.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| pip | jupyter development team | notebook |
>= 7.0.0, <= 7.2.1 Fix: upgrade to 7.2.2
|
| – | jupyter | jupyterlab |
< 3.6.8 >= 4.0.0, < 4.2.5 cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* |
| – | jupyter | notebook |
>= 7.0.0, < 7.2.2 cpe:2.3:a:jupyter:notebook:*:*:*:*:*:*:*:* |
| pip | jupyter development team | jupyterlab |
<= 3.6.7 >= 4.0.0, <= 4.2.4 Fix: upgrade to 3.6.8
|
| PyPI | jupyter development team | notebook |
>= 7.0.0, < 7.2.2 Fix: upgrade to 7.2.2
|
| Bitnami | – | jupyter-notebook |
>= 7.0.0, < 7.2.2 Fix: upgrade to 7.2.2
|
| Bitnami | – | jupyterlab |
< 4.2.5 Fix: upgrade to 4.2.5
|
| Bitnami | – | jupyter-base-notebook | >= 7.0.0 |
| Debian:13 | debian | jupyterlab |
< 4.0.11+ds1+~cs11.25.27-3 Fix: upgrade to 4.0.11+ds1+~cs11.25.27-3
|
| Ubuntu:25.10 | canonical | jupyterlab | All versions |
Original advisory text
HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering
jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. This vulnerability depends on user interaction by opening a malicious notebook with Markdown cells, or Markdown file using JupyterLab preview feature. A malicious user can access any data that the attacked user has access to as well as perform arbitrary requests acting as the attacked user. JupyterLab v3.6.8, v4.2.5 and Jupyter Notebook v7.2.2 have been patched to resolve this issue. Users are advised to upgrade. There is no workaround for the underlying DOM Clobbering susceptibility. However, select plugins can be disabled on deployments which cannot update in a timely fashion to minimise the risk. These are: 1. `@jupyterlab/mathjax-extension:plugin` - users will loose ability to preview mathematical equations. 2. `@jupyterlab/markdownviewer-extension:plugin` - users will loose ability to open Markdown previews. 3. `@jupyterlab/mathjax2-extension:plugin` (if installed with optional `jupyterlab-mathjax2` package) - an older version of the mathjax plugin for JupyterLab 4.x. To disable these extensions run: ```jupyter labextension disable @jupyterlab/markdownviewer-extension:plugin && jupyter labextension disable @jupyterlab/mathjax-extension:plugin && jupyter labextension disable @jupyterlab/mathjax2-extension:plugin ``` in bash.
References
- https://github.com/jupyterlab/jupyterlab/commit/06ad9de836f155add7d3d651ef936cc4...
- https://github.com/jupyterlab/jupyterlab/commit/88e24baac551196f9cb3de16bd060a7a...
- https://github.com/advisories/GHSA-9q39-rmj3-p4r2
- https://github.com/jupyterlab/jupyterlab Product
- https://pypi.org/project/jupyterlab Product
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-9q39-rmj3-p4r2 Vendor Advisory
- https://nvd.nist.gov/vuln/detail/CVE-2024-43805 Vendor Advisory
- https://security-tracker.debian.org/tracker/CVE-2024-43805 Vendor Advisory
- https://ubuntu.com/security/CVE-2024-43805 Third Party Advisory
- https://www.cve.org/CVERecord?id=CVE-2024-43805 Third Party Advisory
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/43xxx/CVE-2024-43805... Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Severity
8.9
High
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published28 Aug 2024
Updated4 Nov 2026
First seen6 Mar 2026
Sources
GHSA-9q39-rmj3-p4r2 · GHSA
CVE-2024-43805 · NVD
PYSEC-2026-1481 · OSV
DEBIAN-CVE-2024-43805 · OSV
UBUNTU-CVE-2024-43805 · OSV
CVE-2024-43805 · OSV
Track software like this
Free during beta