Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.8

CVE-2024-4181: llama-index library can let host run any command

CVE-2024-4181 · published 2 years ago
Summary

The RunGptLLM component in the llama-index library (versions before 0.10.13) uses a function that can be tricked into executing commands on your computer. If the language model service you connect to is malicious, it could run any code on your system. Upgrade the library to version 0.10.13 or later to stop this risk.

What to do
  • Update jerry liu llama-index to version 0.10.13.
  • Update your name llama-index-llms-rungpt to version 0.1.3.
  • Update llamaindex llamaindex to version 0.10.13 or later.
Affected software
Ecosystem VendorProductAffected versions
pip jerry liu llama-index < 0.10.13
Fix: upgrade to 0.10.13
pip your name llama-index-llms-rungpt < 0.1.3
Fix: upgrade to 0.1.3
– llamaindex llamaindex >= 0.9.47, < 0.10.13
cpe:2.3:a:llamaindex:llamaindex:*:*:*:*:*:*:*:*
Original advisory text
Command Injection in run-llama/llama_index
A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
8.8 High
Exploitation
2% chance of attack within 30 days
Type
CWE-94Code Injection
Timeline
Published16 May 2024
Updated4 Nov 2026
First seen6 Mar 2026
Sources
CVE-2024-4181 · NVD
CVE-2024-4181 · OSV
Track software like this
Free during beta