Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.1
CVE-2024-38791: Jordy Meow AI Engine ChatGPT Chatbot allows hackers to make unauthorized requests
CVE-2024-38791 · published 2 years ago
Summary
A security weakness in Jordy Meow's AI Engine ChatGPT Chatbot allows hackers to trick the system into making requests to unintended servers. This could lead to sensitive data exposure or website compromise. Update to version 2.4.8 or later to fix the issue.
What to do
- Update meowapps ai_engine to version 2.4.8 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| meowapps | ai_engine |
< 2.4.8 cpe:2.3:a:meowapps:ai_engine:*:*:*:*:*:wordpress:*:* |
Original advisory text
Server-Side Request Forgery (SSRF) vulnerability in Jordy Meow AI Engine: ChatGPT Chatbot allows Server Side Request Forgery.This issue affects AI Engine: ChatGPT Chatbot: from n/a through 2.4.7.
Server-Side Request Forgery (SSRF) vulnerability in Jordy Meow AI Engine: ChatGPT Chatbot allows Server Side Request Forgery.This issue affects AI Engine: ChatGPT Chatbot: from n/a through 2.4.7.
References
- https://patchstack.com/database/vulnerability/ai-engine/wordpress-ai-engine-plug... Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-918Server-Side Request Forgery (SSRF)
Timeline
Published1 Aug 2024
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-38791 · NVD
Track software like this
Free during beta