Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.5
CVE-2024-34795: WordPress Tainacan plugin <= 0.21.3 - Cross Site Scripting (XSS) vulnerability
CVE-2024-34795 · published 2 years ago
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in tainacan Tainacan tainacan.This issue affects Tainacan: from n/a through <= 0.21.3.
What to do
- Update tainacan tainacan to version 0.21.4 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| tainacan | tainacan |
< 0.21.4 cpe:2.3:a:tainacan:tainacan:*:*:*:*:*:wordpress:*:* |
Original advisory text
WordPress Tainacan plugin <= 0.21.3 - Cross Site Scripting (XSS) vulnerability
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in tainacan Tainacan tainacan.This issue affects Tainacan: from n/a through <= 0.21.3.
References
- https://wordpress.org/plugins URL
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/34xxx/CVE-2024-34795... Vendor Advisory
- https://nvd.nist.gov/vuln/detail/CVE-2024-34795 Vendor Advisory
- https://patchstack.com/database/Wordpress/Plugin/tainacan/vulnerability/wordpres... Vendor Advisory
- https://patchstack.com/database/vulnerability/tainacan/wordpress-tainacan-plugin... Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Severity
6.5
Medium
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published3 Jun 2024
Updated4 Nov 2026
First seen29 Sep 2026
Track software like this
Free during beta