Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2024-34596: Improper authentication in SmartThings prior to version 1.8.17 allows remote attackers to bypass the expiration date for members set by the owner.

CVE-2024-34596 · published 2 years ago
Summary

Improper authentication in SmartThings prior to version 1.8.17 allows remote attackers to bypass the expiration date for members set by the owner.

What to do
  • Update samsung smartthings to version 1.8.17 or later.
Affected software
VendorProductAffected versions
samsung smartthings < 1.8.17
cpe:2.3:a:samsung:smartthings:*:*:*:*:*:*:*:*
Original advisory text
Improper authentication in SmartThings prior to version 1.8.17 allows remote attackers to bypass the expiration date for members set by the owner.
Improper authentication in SmartThings prior to version 1.8.17 allows remote attackers to bypass the expiration date for members set by the owner.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
7.5 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-287Improper Authentication
Timeline
Published2 Jul 2024
Updated4 Nov 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta