Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.5
CVE-2024-31493: An improper removal of sensitive information before storage or transfer vulnerability [CWE-212] in FortiSOAR version 7.3.0, version 7.2.2 and below, version 7.0.3 and below may allow an authenticat...
CVE-2024-31493 · published 2 years ago
Summary
An improper removal of sensitive information before storage or transfer vulnerability [CWE-212] in FortiSOAR version 7.3.0, version 7.2.2 and below, version 7.0.3 and below may allow an authenticated low privileged user to read Connector passwords in plain-text via HTTP responses.
What to do
- Update fortinet fortisoar to version 7.3.1 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| fortinet | fortisoar |
>= 7.0.0, < 7.3.1 cpe:2.3:a:fortinet:fortisoar:*:*:*:*:*:*:*:* |
Original advisory text
An improper removal of sensitive information before storage or transfer vulnerability [CWE-212] in FortiSOAR version 7.3.0, version 7.2.2 and below, version 7.0.3 and below may allow an authenticat...
An improper removal of sensitive information before storage or transfer vulnerability [CWE-212] in FortiSOAR version 7.3.0, version 7.2.2 and below, version 7.0.3 and below may allow an authenticated low privileged user to read Connector passwords in plain-text via HTTP responses.
References
- https://fortiguard.fortinet.com/psirt/FG-IR-24-052 Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-212Improper Removal of Sensitive Information Before Storage or Transfer
Timeline
Published3 Jun 2024
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2024-31493 · NVD
Track software like this
Free during beta