Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.1

CVE-2024-28709: LimeSurvey 6.5.12 and earlier: Malicious scripts injected via survey comments

CVE-2024-28709 · published 2 years ago
Summary

A security weakness in LimeSurvey's survey comments feature allows an attacker to inject malicious code, potentially allowing them to take control of your website. This is a serious issue because an attacker could exploit it to steal sensitive information or disrupt your site. To fix this, update to LimeSurvey 6.5.12 or later.

What to do
  • Update limesurvey limesurvey to version 6.5.12.
Affected software
Ecosystem VendorProductAffected versions
composer limesurvey limesurvey < 6.5.12
Fix: upgrade to 6.5.12
– limesurvey limesurvey < 6.5.12\+240611
cpe:2.3:a:limesurvey:limesurvey:*:*:*:*:*:*:*:*
Original advisory text
Cross Site Scripting vulnerability in LimeSurvey before 6.5.12+240611 allows a remote attacker to execute arbitrary code via a crafted script to the title and comment fields.
Cross Site Scripting vulnerability in LimeSurvey before 6.5.12+240611 allows a remote attacker to execute arbitrary code via a crafted script to the title and comment fields.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
5.1 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published7 Oct 2024
Updated4 Nov 2026
First seen6 Mar 2026
Sources
CVE-2024-28709 · MITRE
Track software like this
Free during beta