Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.8

CVE-2024-28107: phpMyFAQ: Authenticated User Can Exfiltrate Data and Take Over Accounts

CVE-2024-28107 · published 2 years ago
Summary

An issue has been found in a popular FAQ web application that could allow an authenticated user to steal sensitive information and take control of other user accounts. This issue affects PHP-based FAQs using MySQL, PostgreSQL, or other databases. Update to version 3.2.6 to fix the problem.

What to do
  • Update phpmyfaq phpmyfaq to version 3.2.6.
Affected software
Ecosystem VendorProductAffected versions
composer phpmyfaq phpmyfaq 3.2.5
Fix: upgrade to 3.2.6
Original advisory text
phpMyFAQ SQL injections at insertentry & saveentry
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. A SQL injection vulnerability has been discovered in the `insertentry` & `saveentry` when modifying records due to improper escaping of the email address. This allows any authenticated user with the rights to add/edit FAQ news to exploit this vulnerability to exfiltrate data, take over accounts and in some cases, even achieve RCE. This vulnerability is fixed in 3.2.6.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
8.8 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-89SQL Injection
Timeline
Published25 Mar 2024
Updated3 Nov 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta