Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.9

CVE-2024-2236: libgcrypt lets remote attacker decrypt RSA data

CVE-2024-2236 · published 2 years ago
Summary

The libgcrypt library used in several Debian and Ubuntu packages has a flaw that lets a remote attacker slowly extract secret information from RSA-encrypted messages. This could let the attacker read sensitive data that was thought to be protected. Apply the latest security updates for the libgcrypt packages as soon as possible.

What to do
  • Update debian rootio-libgcrypt20 to version 1.10.1-3.root.io.4.
  • Update canonical rootio-libgcrypt20 to version 1.9.4-3ubuntu3.root.io.2.
  • Update canonical libgcrypt20 to version 1.9.4-3ubuntu3.root.io.2.
  • Update canonical libgcrypt20 to version 1.9.4-3ubuntu3.3.
  • Update canonical libgcrypt20 to version 1.10.3-2ubuntu0.2.
  • Update canonical libgcrypt20 to version 1.12.0-2ubuntu1.1.
  • Update canonical libgcrypt20 to version 1.9.4-3ubuntu3.3+Fips1.
  • Update canonical libgcrypt20 to version 1.12.0-2ubuntu1.1+Fips2.
  • Update libgcrypt20 to version 1.9.4-3ubuntu3.root.io.2.
  • Update rootio-libgcrypt20 to version 1.9.4-3ubuntu3.root.io.2.
Affected software
Ecosystem VendorProductAffected versions
Root:Debian:12 debian rootio-libgcrypt20 < 1.10.1-3.root.io.4
Fix: upgrade to 1.10.1-3.root.io.4
Ubuntu:Pro:14.04:LTS canonical libgcrypt11 All versions
Ubuntu:Pro:16.04:LTS canonical libgcrypt20 All versions
Ubuntu:18.04:LTS canonical libgcrypt20 All versions
Ubuntu:Pro:FIPS-updates:18.04:LTS canonical libgcrypt20 All versions
Ubuntu:Pro:FIPS:18.04:LTS canonical libgcrypt20 All versions
Ubuntu:20.04:LTS canonical libgcrypt20 All versions
Ubuntu:Pro:FIPS-updates:20.04:LTS canonical libgcrypt20 All versions
Ubuntu:Pro:FIPS:20.04:LTS canonical libgcrypt20 All versions
Ubuntu:22.04:LTS canonical libgcrypt20 < 1.9.4-3ubuntu3.3
Fix: upgrade to 1.9.4-3ubuntu3.3
Ubuntu:Pro:FIPS-preview:22.04:LTS canonical libgcrypt20 All versions
Ubuntu:Pro:FIPS-updates:22.04:LTS canonical libgcrypt20 < 1.9.4-3ubuntu3.3+Fips1
Fix: upgrade to 1.9.4-3ubuntu3.3+Fips1
Ubuntu:24.04:LTS canonical libgcrypt20 < 1.10.3-2ubuntu0.2
Fix: upgrade to 1.10.3-2ubuntu0.2
Ubuntu:Pro:FIPS-updates:24.04:LTS canonical libgcrypt20 < 1.12.0-2ubuntu1.1+Fips2
Fix: upgrade to 1.12.0-2ubuntu1.1+Fips2
Ubuntu:25.10 canonical libgcrypt20 All versions
Ubuntu:26.04:LTS canonical libgcrypt20 < 1.12.0-2ubuntu1.1
Fix: upgrade to 1.12.0-2ubuntu1.1
Root:Ubuntu:22.04 canonical rootio-libgcrypt20 < 1.9.4-3ubuntu3.root.io.2
Fix: upgrade to 1.9.4-3ubuntu3.root.io.2
Root:Ubuntu:22.04 canonical libgcrypt20 < 1.9.4-3ubuntu3.root.io.2
Fix: upgrade to 1.9.4-3ubuntu3.root.io.2
Root:Ubuntu:22.04 – libgcrypt20 < 1.9.4-3ubuntu3.root.io.2
Fix: upgrade to 1.9.4-3ubuntu3.root.io.2
Root:Ubuntu:22.04 – rootio-libgcrypt20 < 1.9.4-3ubuntu3.root.io.2
Fix: upgrade to 1.9.4-3ubuntu3.root.io.2
Original advisory text
CVE-2024-2236 in libgcrypt20 - Patched by Root
A timing-based side-channel flaw was found in libgcrypt's RSA implementation. This issue may allow a remote attacker to initiate a Bleichenbacher-style attack, which can lead to the decryption of RSA ciphertexts.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
5.9 Medium
Exploitation
1% chance of attack within 30 days
Type
CWE-385Covert Timing Channel
Timeline
Published6 Mar 2024
Updated4 Nov 2026
First seen23 Apr 2026
Track software like this
Free during beta