Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.6
CVE-2024-22129: SAP Companion - version <3.1.38, has a URL with parameter that could be vulnerable to XSS attack. The attacker could send a malicious link to a user that would possibly allow an attacker to retriev...
CVE-2024-22129 · published 2 years ago
Summary
SAP Companion - version <3.1.38, has a URL with parameter that could be vulnerable to XSS attack. The attacker could send a malicious link to a user that would possibly allow an attacker to retrieve the sensitive information and cause minor impact on the integrity of the web application.
What to do
- Update sap companion to version 3.1.38 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| sap | companion |
< 3.1.38 cpe:2.3:a:sap:companion:*:*:*:*:*:*:*:* |
Original advisory text
SAP Companion - version <3.1.38, has a URL with parameter that could be vulnerable to XSS attack. The attacker could send a malicious link to a user that would possibly allow an attacker to retriev...
SAP Companion - version <3.1.38, has a URL with parameter that could be vulnerable to XSS attack. The attacker could send a malicious link to a user that would possibly allow an attacker to retrieve the sensitive information and cause minor impact on the integrity of the web application.
References
- https://me.sap.com/notes/3404025 Permissions Required
- https://www.sap.com/documents/2022/02/fa865ea4-167e-0010-bca6-c68f7e60039b.html Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published13 Feb 2024
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2024-22129 · NVD
Track software like this
Free during beta