Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.4
CVE-2024-1948: The Getwid – Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the block content in all versions up to, and including, 2.0.5 due to insufficient input sanitizat...
CVE-2024-1948 · published 2 years ago
Summary
The Getwid – Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the block content in all versions up to, and including, 2.0.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor access an...
What to do
- Update motopress getwid to version 2.0.6 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| motopress | getwid |
< 2.0.6 cpe:2.3:a:motopress:getwid:*:*:*:*:*:wordpress:*:* |
Original advisory text
The Getwid – Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the block content in all versions up to, and including, 2.0.5 due to insufficient input sanitizat...
The Getwid – Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the block content in all versions up to, and including, 2.0.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published9 Apr 2024
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2024-1948 · NVD
Track software like this
Free during beta