Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.4
CVE-2024-13741: ProfileGrid Plugin Allows Attackers to Access Server Files
CVE-2024-13741 · published 1 year ago
Summary
The ProfileGrid plugin for WordPress has a security flaw that lets attackers with a basic account access and view files on the server. This can be done by tricking the server into showing files that shouldn't be accessible. To fix this, update the ProfileGrid plugin to version 5.9.4.3 or later.
What to do
- Update metagauss profilegrid to version 5.9.4.3 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| metagauss | profilegrid |
< 5.9.4.3 cpe:2.3:a:metagauss:profilegrid:*:*:*:*:*:wordpress:*:* |
Original advisory text
The ProfileGrid – User Profiles, Groups and Communities plugin for WordPress is vulnerable to Limited Server-Side Request Forgery in all versions up to, and including, 5.9.4.2 via the pm_upload_ima...
The ProfileGrid – User Profiles, Groups and Communities plugin for WordPress is vulnerable to Limited Server-Side Request Forgery in all versions up to, and including, 5.9.4.2 via the pm_upload_image function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to download and view images, as well as validating if a non-image file exists, both on local or remote hosts.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-918Server-Side Request Forgery (SSRF)
Timeline
Published18 Feb 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-13741 · NVD
Track software like this
Free during beta