Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2024-1331: The Team Members WordPress plugin before 5.3.2 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could all...
CVE-2024-1331 · published 2 years ago
Summary
The Team Members WordPress plugin before 5.3.2 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the author role and above to perform Stored Cross-Site Scripting attacks.
What to do
- Update wpdarko team_members to version 5.3.2 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| wpdarko | team_members |
< 5.3.2 cpe:2.3:a:wpdarko:team_members:*:*:*:*:*:wordpress:*:* |
Original advisory text
The Team Members WordPress plugin before 5.3.2 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could all...
The Team Members WordPress plugin before 5.3.2 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the author role and above to perform Stored Cross-Site Scripting attacks.
References
- https://wpscan.com/vulnerability/b2bac900-3d8f-406c-b03d-c8db156acc59/ Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published18 Mar 2024
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2024-1331 · NVD
Track software like this
Free during beta