Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.8
CVE-2024-13247: Drupal Coffee: Hackers can inject malicious code into web pages
CVE-2024-13247 · published 1 year ago
Summary
The Drupal Coffee module is vulnerable to a security issue that allows hackers to inject malicious code into web pages. This could lead to unauthorized access to sensitive information or the spread of malware. Update to version 1.4.0 or later to fix the issue.
What to do
- Update coffee_project coffee to version 8.x-1.4 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| coffee_project | coffee |
>= 7.x-1.0, < 8.x-1.4 cpe:2.3:a:coffee_project:coffee:*:*:*:*:*:drupal:*:* |
Original advisory text
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Coffee allows Cross-Site Scripting (XSS).This issue affects Coffee: from 0.0.0 before 1....
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Coffee allows Cross-Site Scripting (XSS).This issue affects Coffee: from 0.0.0 before 1.4.0.
References
- https://www.drupal.org/sa-contrib-2024-011 Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published9 Jan 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-13247 · NVD
Track software like this
Free during beta