Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.3
CVE-2024-1322: The Directorist – WordPress Business Directory Plugin with Classified Ads Listings plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the '...
CVE-2024-1322 · published 2 years ago
Summary
The Directorist – WordPress Business Directory Plugin with Classified Ads Listings plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'setup_wizard' function in all versions up to, and including, 7.8.4. This makes it possible for unauthen...
What to do
- Update wpwax directorist to version 7.8.5 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| wpwax | directorist |
< 7.8.5 cpe:2.3:a:wpwax:directorist:*:*:*:*:*:wordpress:*:* |
Original advisory text
The Directorist – WordPress Business Directory Plugin with Classified Ads Listings plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the '...
The Directorist – WordPress Business Directory Plugin with Classified Ads Listings plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'setup_wizard' function in all versions up to, and including, 7.8.4. This makes it possible for unauthenticated attackers to recreate default pages and enable or disable monetization and change map provider.
Internet-facing
14 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically
- Gives an attacker partial control
Type
CWE-862Missing Authorization
Timeline
Published29 Feb 2024
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2024-1322 · NVD
Track software like this
Free during beta