Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2024-1311: The Brizy – Page Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the storeImages function in all versions up to, and including, 2.4.40. T...
CVE-2024-1311 · published 2 years ago
Summary
The Brizy – Page Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the storeImages function in all versions up to, and including, 2.4.40. This makes it possible for authenticated attackers, with contributor access or above, to upload arbitrar...
What to do
- Update brizy brizy to version 2.4.41 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| brizy | brizy |
< 2.4.41 cpe:2.3:a:brizy:brizy:*:*:*:*:free:wordpress:*:* |
Original advisory text
The Brizy – Page Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the storeImages function in all versions up to, and including, 2.4.40. T...
The Brizy – Page Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the storeImages function in all versions up to, and including, 2.4.40. This makes it possible for authenticated attackers, with contributor access or above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Type
CWE-434Unrestricted File Upload
Timeline
Published13 Mar 2024
Updated31 Oct 2026
First seen29 Sep 2026
Sources
CVE-2024-1311 · NVD
Track software like this
Free during beta