Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2024-12682: Smart Maintenance Mode Plugin Allows Admins to Inject Malicious Code
CVE-2024-12682 · published 1 year ago
Summary
The Smart Maintenance Mode WordPress plugin has a security issue that allows administrators to inject malicious code into the website, even when security settings are in place. This could lead to unauthorized actions and potentially compromise the website's security. To fix this, update the plugin to version 1.5.2 or later.
What to do
- Update brijeshk89 smart_maintenance_mode to version 1.5.2 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| brijeshk89 | smart_maintenance_mode |
< 1.5.2 cpe:2.3:a:brijeshk89:smart_maintenance_mode:*:*:*:*:*:wordpress:*:* |
Original advisory text
The Smart Maintenance Mode WordPress plugin before 1.5.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripti...
The Smart Maintenance Mode WordPress plugin before 1.5.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
References
- https://wpscan.com/vulnerability/79d0a139-0fb3-4a4b-ac33-80cbc6cb3831/ Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published25 Mar 2025
Updated3 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-12682 · NVD
Track software like this
Free during beta