Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.4
CVE-2024-12599: HT Mega – Absolute Addons For Elementor plugin Countdown widget allows script injection
CVE-2024-12599 · published 1 year ago
Summary
A security flaw in the HT Mega – Absolute Addons For Elementor plugin for WordPress allows attackers with contributor access to inject malicious scripts into certain pages. This could allow them to take control of your website or steal sensitive information. Update the plugin to a version newer than 2.8.1 to fix the issue.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| hasthemes | ht_mega |
<= 2.8.1 cpe:2.3:a:hasthemes:ht_mega:*:*:*:*:free:wordpress:*:* |
Original advisory text
The HT Mega – Absolute Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Countdown widget in all versions up to, and including, 2.8.1 due to in...
The HT Mega – Absolute Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Countdown widget in all versions up to, and including, 2.8.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Internet-facing
14 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically
- Gives an attacker partial control
Severity
6.4
Medium
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published11 Feb 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-12599 · NVD
Track software like this
Free during beta