Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.1

CVE-2024-12122: ResAds WordPress Plugin Can Execute Malicious Scripts

CVE-2024-12122 · published 1 year ago
Summary

The ResAds plugin for WordPress is not properly filtering user input, which allows attackers to trick users into executing malicious scripts. This can lead to unauthorized actions being performed on a website. Update to version 2.0.7 or later to fix the issue.

Original advisory text
The ResAds plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via multiple parameters in all versions up to, and including, 2.0.6 due to insufficient input sanitization and output...
The ResAds plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via multiple parameters in all versions up to, and including, 2.0.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
6.1 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published9 Jan 2025
Updated3 Nov 2026
First seen7 Mar 2026
Sources
Track software like this
Free during beta