Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2024-12096: Exhibit to WP Gallery WordPress Plugin Allows Malicious Scripts on Admin Pages
CVE-2024-12096 · published 1 year ago
Summary
The Exhibit to WP Gallery plugin for WordPress does not properly protect admin pages from malicious scripts. This can allow an attacker to inject code into the site's admin area, potentially giving them access to sensitive information or causing other issues. Update the plugin to the latest version (0.0.3 or higher) to fix this issue.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| ulfben | exhibit_to_wp_gallery |
<= 0.0.2 cpe:2.3:a:ulfben:exhibit_to_wp_gallery:*:*:*:*:*:wordpress:*:* |
Original advisory text
The Exhibit to WP Gallery WordPress plugin through 0.0.2 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be u...
The Exhibit to WP Gallery WordPress plugin through 0.0.2 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
References
- https://wpscan.com/vulnerability/aff431fa-d984-40de-8a15-21f18db97859/ Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published24 Dec 2024
Updated31 Oct 2026
First seen7 Mar 2026
Sources
CVE-2024-12096 · NVD
Track software like this
Free during beta