Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2024-11188: WordPress Formidable Forms Plugin Allows Hackers to Inject Malicious Scripts
CVE-2024-11188 · published 1 year ago
Summary
A security flaw in the Formidable Forms plugin for WordPress allows hackers to inject malicious scripts into pages if they trick users into clicking on a link. This could lead to a range of issues, including stealing sensitive information or taking control of the website. To protect your website, update the Formidable Forms plugin to the latest version or consider replacing it with an alternative plugin.
What to do
- Update strategy11 formidable_forms to version 6.16.2 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| strategy11 | formidable_forms |
< 6.16.2 cpe:2.3:a:strategy11:formidable_forms:*:*:*:*:free:wordpress:*:* |
Original advisory text
The Formidable Forms – Contact Form Plugin, Survey, Quiz, Payment, Calculator Form & Custom Form Builder plugin for WordPress is vulnerable to POST-Based Reflected Cross-Site Scripting via the Cust...
The Formidable Forms – Contact Form Plugin, Survey, Quiz, Payment, Calculator Form & Custom Form Builder plugin for WordPress is vulnerable to POST-Based Reflected Cross-Site Scripting via the Custom HTML Form parameters in all versions up to, and including, 6.16.1.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published23 Nov 2024
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-11188 · NVD
Track software like this
Free during beta