Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.8
CVE-2024-10149: The Social Slider Feed WordPress plugin before 2.2.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting a...
CVE-2024-10149 · published 1 year ago
Summary
The Social Slider Feed WordPress plugin before 2.2.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
What to do
- Update cm-wp social_slider_widget to version 2.2.9 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| cm-wp | social_slider_widget |
< 2.2.9 cpe:2.3:a:cm-wp:social_slider_widget:*:*:*:*:*:wordpress:*:* |
Original advisory text
The Social Slider Feed WordPress plugin before 2.2.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting a...
The Social Slider Feed WordPress plugin before 2.2.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
References
- https://wpscan.com/vulnerability/1619dc4b-4e5e-4b82-820b-3c4e732db3ad/ Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published15 May 2025
Updated31 Oct 2026
First seen29 Sep 2026
Sources
CVE-2024-10149 · NVD
Track software like this
Free during beta