Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.8
CVE-2024-10010: LearnPress WordPress Plugin Allows Admins to Inject Malicious Code
CVE-2024-10010 · published 1 year ago
Summary
If an admin uses the LearnPress WordPress plugin, they could potentially inject malicious code into the website, allowing an attacker to take control of the site. This could happen even if the website has security settings in place to prevent this type of attack. To fix this, update the LearnPress plugin to version 4.2.7.2 or higher.
What to do
- Update thimpress learnpress to version 4.2.7.2 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| thimpress | learnpress |
< 4.2.7.2 cpe:2.3:a:thimpress:learnpress:*:*:*:*:*:wordpress:*:* |
Original advisory text
The LearnPress WordPress plugin before 4.2.7.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attack...
The LearnPress WordPress plugin before 4.2.7.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
References
- https://wpscan.com/vulnerability/8a258d33-a354-4cbb-bfcb-31b7f1b1a036/ Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published12 Dec 2024
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-10010 · NVD
Track software like this
Free during beta