Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2023-7170: The EventON-RSVP WordPress plugin before 2.9.5 does not sanitise and escape some parameters before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used ag...
CVE-2023-7170 · published 2 years ago
Summary
The EventON-RSVP WordPress plugin before 2.9.5 does not sanitise and escape some parameters before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
What to do
- Update myeventon rsvp_events to version 2.9.5 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| myeventon | rsvp_events |
< 2.9.5 cpe:2.3:a:myeventon:rsvp_events:*:*:*:*:*:wordpress:*:* |
Original advisory text
The EventON-RSVP WordPress plugin before 2.9.5 does not sanitise and escape some parameters before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used ag...
The EventON-RSVP WordPress plugin before 2.9.5 does not sanitise and escape some parameters before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
References
- https://wpscan.com/vulnerability/218fb3af-3a40-486f-8ea9-80211a986fb3/ Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published22 Jan 2024
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2023-7170 · NVD
Track software like this
Free during beta