Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.4

CVE-2023-6806: The Starbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Job Settings user profile fields in all versions up to, and including, 3.4.8 due to insufficient input sanitiza...

CVE-2023-6806 · published 2 years ago
Summary

The Starbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Job Settings user profile fields in all versions up to, and including, 3.4.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level acc...

What to do
  • Update squirrly starbox to version 3.5.0 or later.
Affected software
VendorProductAffected versions
squirrly starbox < 3.5.0
cpe:2.3:a:squirrly:starbox:*:*:*:*:*:wordpress:*:*
Original advisory text
The Starbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Job Settings user profile fields in all versions up to, and including, 3.4.8 due to insufficient input sanitiza...
The Starbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Job Settings user profile fields in all versions up to, and including, 3.4.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
5.4 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published29 Feb 2024
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2023-6806 · NVD
Track software like this
Free during beta