Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2023-6567: The LearnPress plugin for WordPress is vulnerable to time-based SQL Injection via the ‘order_by’ parameter in all versions up to, and including, 4.2.5.7 due to insufficient escaping on the user sup...

CVE-2023-6567 · published 2 years ago
Summary

The LearnPress plugin for WordPress is vulnerable to time-based SQL Injection via the ‘order_by’ parameter in all versions up to, and including, 4.2.5.7 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible f...

What to do
  • Update thimpress learnpress to version 4.2.5.8 or later.
Affected software
VendorProductAffected versions
thimpress learnpress < 4.2.5.8
cpe:2.3:a:thimpress:learnpress:*:*:*:*:*:wordpress:*:*
Original advisory text
The LearnPress plugin for WordPress is vulnerable to time-based SQL Injection via the ‘order_by’ parameter in all versions up to, and including, 4.2.5.7 due to insufficient escaping on the user sup...
The LearnPress plugin for WordPress is vulnerable to time-based SQL Injection via the ‘order_by’ parameter in all versions up to, and including, 4.2.5.7 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically
  • Gives an attacker partial control
Severity
7.5 High
Exploitation
51% chance of attack within 30 days
Type
CWE-89SQL Injection
Timeline
Published11 Jan 2024
Updated30 Sep 2026
First seen29 Sep 2026
Sources
CVE-2023-6567 · NVD
Track software like this
Free during beta