Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.4

CVE-2023-5861: GitHub microweber/microweber Stored Cross-Site Scripting

CVE-2023-5861 · published 3 years ago
Summary

A stored cross-site scripting issue has been found in GitHub's microweber/microweber repository. This means that an attacker could inject malicious code into the system, potentially allowing them to steal user data or take control of a website. To protect your site, update to version 2.0 or later.

What to do
  • Update microweber microweber to version 2.0.0.
Affected software
Ecosystem VendorProductAffected versions
composer microweber microweber < 2.0.0
Fix: upgrade to 2.0.0
Original advisory text
Cross-site Scripting (XSS) - Stored in microweber/microweber
Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 2.0.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
6.4 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published31 Oct 2023
Updated4 Nov 2026
First seen6 Mar 2026
Sources
CVE-2023-5861 · NVD
CVE-2023-5861 · OSV
Track software like this
Free during beta