Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.8
CVE-2023-5124: The Page Builder: Pagelayer WordPress plugin before 1.8.0 doesn't prevent attackers with administrator privileges from inserting malicious JavaScript inside a post's header or footer code, even whe...
CVE-2023-5124 · published 2 years ago
Summary
The Page Builder: Pagelayer WordPress plugin before 1.8.0 doesn't prevent attackers with administrator privileges from inserting malicious JavaScript inside a post's header or footer code, even when unfiltered_html is disallowed, such as in multi-site WordPress configurations.
What to do
- Update pagelayer pagelayer to version 1.8.0 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| pagelayer | pagelayer |
< 1.8.0 cpe:2.3:a:pagelayer:pagelayer:*:*:*:*:*:wordpress:*:* |
Original advisory text
The Page Builder: Pagelayer WordPress plugin before 1.8.0 doesn't prevent attackers with administrator privileges from inserting malicious JavaScript inside a post's header or footer code, even whe...
The Page Builder: Pagelayer WordPress plugin before 1.8.0 doesn't prevent attackers with administrator privileges from inserting malicious JavaScript inside a post's header or footer code, even when unfiltered_html is disallowed, such as in multi-site WordPress configurations.
References
- https://wpscan.com/vulnerability/1ef86546-3467-432c-a863-1ca3e5c65bd4/ Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published29 Jan 2024
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2023-5124 · NVD
Track software like this
Free during beta