Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.4
CVE-2023-5057: The ActivityPub WordPress plugin before 1.0.0 does not escape user metadata before outputting them in mentions, which could allow users with a role of Contributor and above to perform Stored XSS at...
CVE-2023-5057 · published 3 years ago
Summary
The ActivityPub WordPress plugin before 1.0.0 does not escape user metadata before outputting them in mentions, which could allow users with a role of Contributor and above to perform Stored XSS attacks
What to do
- Update automattic activitypub to version 1.0.0 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| automattic | activitypub |
< 1.0.0 cpe:2.3:a:automattic:activitypub:*:*:*:*:*:wordpress:*:* |
Original advisory text
The ActivityPub WordPress plugin before 1.0.0 does not escape user metadata before outputting them in mentions, which could allow users with a role of Contributor and above to perform Stored XSS at...
The ActivityPub WordPress plugin before 1.0.0 does not escape user metadata before outputting them in mentions, which could allow users with a role of Contributor and above to perform Stored XSS attacks
References
- https://wpscan.com/vulnerability/58a63507-f0fd-46f1-a80c-6b1c41dddcf5 Exploit Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Timeline
Published16 Oct 2023
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2023-5057 · NVD
Track software like this
Free during beta