Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.8

CVE-2023-50245: OpenEXR-viewer can crash before version 0.6.1

CVE-2023-50245 · published 2 years ago
Summary

Versions of OpenEXR-viewer released before 0.6.1 can run out of memory, which may cause the program to stop working or be taken over by an attacker. The problem is fixed in version 0.6.1. Upgrade to version 0.6.1 or later to eliminate the risk.

What to do
  • Update afichet openexr-viewer to version 0.6.1.
  • Update afichet openexr_viewer to version 0.6.1 or later.
Affected software
Ecosystem VendorProductAffected versions
actions afichet openexr-viewer < 0.6.1
Fix: upgrade to 0.6.1
– afichet openexr_viewer < 0.6.1
cpe:2.3:a:afichet:openexr_viewer:*:*:*:*:*:*:*:*
Original advisory text
OpenEXR-viewer memory overflow vulnerability
OpenEXR-viewer is a viewer for OpenEXR files with detailed metadata probing. Versions prior to 0.6.1 have a memory overflow vulnerability. This issue is fixed in version 0.6.1.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker full control (estimated)
Severity
9.8 Critical
Exploitation
1% chance of attack within 30 days
Type
CWE-120Classic Buffer Overflow
Timeline
Published11 Dec 2023
Updated31 Oct 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta