Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.3
CVE-2023-46288: Apache Airflow may reveal secret settings via API
CVE-2023-46288 · published 3 years ago
Summary
In versions 2.4.0 through 2.7.0, the Airflow REST API can return configuration details that should be hidden, even when the system is set to show only non‑sensitive items. An attacker who can log in could view passwords, keys, or other private settings. Upgrade to version 2.7.2 or later, where the problem is fixed.
What to do
- Update apache software foundation apache-airflow to version 2.7.2.
- Update apache airflow to version 2.7.0 or later.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| pip | apache software foundation | apache-airflow |
>= 2.4.0, < 2.7.2 Fix: upgrade to 2.7.2
|
| – | apache | airflow |
>= 2.4.0, < 2.7.0 cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:* |
Original advisory text
Apache Airflow: Sensitive parameters exposed in API when "non-sensitive-only" configuration is set
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Airflow.This issue affects Apache Airflow from 2.4.0 to 2.7.0.
Sensitive configuration information has been exposed to authenticated users with the ability to read configuration via Airflow REST API for configuration even when the expose_config option is set to non-sensitive-only. The expose_config option is False by default. It is recommended to upgrade to a version that is not affected if you set expose_config to non-sensitive-only configuration. This is a different error than CVE-2023-45348 which allows authenticated user to retrieve individual configuration values in 2.7.* by specially crafting their request (solved in 2.7.2).
Users are recommended to upgrade to version 2.7.2, which fixes the issue and additionally fixes CVE-2023-45348.
Sensitive configuration information has been exposed to authenticated users with the ability to read configuration via Airflow REST API for configuration even when the expose_config option is set to non-sensitive-only. The expose_config option is False by default. It is recommended to upgrade to a version that is not affected if you set expose_config to non-sensitive-only configuration. This is a different error than CVE-2023-45348 which allows authenticated user to retrieve individual configuration values in 2.7.* by specially crafting their request (solved in 2.7.2).
Users are recommended to upgrade to version 2.7.2, which fixes the issue and additionally fixes CVE-2023-45348.
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-46288 Vendor Advisory
- https://github.com/apache/airflow/pull/32261 Patch
- https://github.com/apache/airflow/commit/4a525e85e31b26d413c986c86d181114bb37bd0...
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2...
- https://github.com/advisories/GHSA-9qqg-mh7c-chfq
- http://www.openwall.com/lists/oss-security/2024/04/17/10 URL
- https://lists.apache.org/thread/yw4vzm0c5lqkwm0bxv6qy03yfd1od4nw Vendor Advisory
- https://pypi.python.org/ URL
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/46xxx/CVE-2023-46288... Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-200Information Exposure
Timeline
Published23 Oct 2023
Updated30 Oct 2026
First seen6 Mar 2026
Track software like this
Free during beta