Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.7
CVE-2023-43665: Django Truncator Method Can Be Exploited to Crash Server
CVE-2023-43665 · published 3 years ago
Summary
A maliciously crafted piece of HTML text can cause a Django server to crash. This affects Django versions 3.2 before 3.2.22, 4.1 before 4.1.12, and 4.2 before 4.2.6. To protect your server, update to the latest version of Django as soon as possible.
What to do
- Update debian python-django to version 3:3.2.25-0+deb12u1.
- Update debian python-django to version 3:4.2.6-1.
- Update django software foundation django to version 3.2.22.
- Update django software foundation django to version 4.1.12.
- Update django software foundation django to version 4.2.6.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| – | djangoproject | django |
>= 3.2, < 3.2.22 >= 4.1, < 4.1.12 >= 4.2, < 4.2.6 cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* |
| – | fedoraproject | fedora |
39 cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* |
| Debian:12 | debian | python-django |
< 3:3.2.25-0+deb12u1 Fix: upgrade to 3:3.2.25-0+deb12u1
|
| Debian:13 | debian | python-django |
< 3:4.2.6-1 Fix: upgrade to 3:4.2.6-1
|
| Debian:14 | debian | python-django |
< 3:4.2.6-1 Fix: upgrade to 3:4.2.6-1
|
| pip | django software foundation | django |
>= 3.2a1, < 3.2.22 >= 4.1a1, < 4.1.12 >= 4.2a1, < 4.2.6 Fix: upgrade to 3.2.22
|
Original advisory text
In Django 3.2 before 3.2.22, 4.1 before 4.1.12, and 4.2 before 4.2.6, the django.utils.text.Truncator chars() and words() methods (when used with html=True) are subject to a potential DoS (denial o...
In Django 3.2 before 3.2.22, 4.1 before 4.1.12, and 4.2 before 4.2.6, the django.utils.text.Truncator chars() and words() methods (when used with html=True) are subject to a potential DoS (denial of service) attack via certain inputs with very long, potentially malformed HTML text. The chars() and words() methods are used to implement the truncatechars_html and truncatewords_html template filters, which are thus also vulnerable. NOTE: this issue exists because of an incomplete fix for CVE-2019-14232.
References
- https://groups.google.com/forum/#!forum/django-announce
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedorapro... Vendor Advisory
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedorapro... Vendor Advisory
- https://nvd.nist.gov/vuln/detail/CVE-2023-43665 Vendor Advisory
- https://security.netapp.com/advisory/ntap-20231221-0001/ Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/03/04/1 Third Party Advisory
- https://www.djangoproject.com/weblog/2023/oct/04/security-releases/ Third Party Advisory
- https://docs.djangoproject.com/en/4.2/releases/security/ URL
- https://groups.google.com/forum/#%21forum/django-announce URL
- https://lists.fedoraproject.org/archives/list/[email protected]... URL
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/43xxx/CVE-2023-43665... Vendor Advisory
- https://github.com/django/django/commit/be9c27c4d18c2e6a5be8af4e53c0797440794473
- https://github.com/django/django/commit/c7b7024742250414e426ad49fb80db943e7ba4e8
- https://github.com/django/django/commit/ccdade1a0262537868d7ca64374de3d957ca50c5
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2023-226....
- https://docs.djangoproject.com/en/4.2/releases/security
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedorapro...
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedorapro...
- https://lists.fedoraproject.org/archives/list/[email protected]...
- https://security.netapp.com/advisory/ntap-20231221-0001
- https://www.djangoproject.com/weblog/2023/oct/04/security-releases
- https://lists.fedoraproject.org/archives/list/[email protected]...
- https://github.com/advisories/GHSA-h8gc-pgj2-vjm3
- https://security-tracker.debian.org/tracker/CVE-2023-43665 Vendor Advisory
Internet-facing
14 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-400Uncontrolled Resource Consumption
CWE-1284Improper Validation of Specified Quantity in Input
Timeline
Published3 Nov 2023
Updated31 Oct 2026
First seen6 Mar 2026
Sources
GHSA-h8gc-pgj2-vjm3 · GHSA
CVE-2023-43665 · NVD
CVE-2023-43665 · OSV
DEBIAN-CVE-2023-43665 · OSV
Track software like this
Free during beta