Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
10.0

CVE-2023-42802: GLPI vulnerable to unallowed PHP script execution

CVE-2023-42802 · published 3 years ago
Summary

GLPI is a free asset and IT management software package. Starting in version 10.0.7 and prior to version 10.0.10, an unverified object instantiation allows one to upload malicious PHP files to unwanted directories. Depending on web server configuration and available system libraries, malicious PHP f...

What to do
  • Update glpi-project glpi to version 10.0.10 or later.
Affected software
VendorProductAffected versions
glpi-project glpi >= 10.0.7, < 10.0.10
cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*
Original advisory text
GLPI vulnerable to unallowed PHP script execution
GLPI is a free asset and IT management software package. Starting in version 10.0.7 and prior to version 10.0.10, an unverified object instantiation allows one to upload malicious PHP files to unwanted directories. Depending on web server configuration and available system libraries, malicious PHP files can then be executed through a web server request. Version 10.0.10 fixes this issue. As a workaround, remove write access on `/ajax` and `/front` files to the web server.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically
  • Gives an attacker full control
Severity
10.0 Critical
Exploitation
1% chance of attack within 30 days
Type
CWE-20Improper Input Validation
CWE-434Unrestricted File Upload
Timeline
Published2 Nov 2023
Updated4 Nov 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta