Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2023-41319: Fides 2.11.0 to 2.19.0 allows unauthorized code execution on server
CVE-2023-41319 · published 3 years ago
Summary
Fides users with the right permissions can upload custom code that can be executed on the server, potentially giving them control over the system. This is a significant risk because the server runs with high-level permissions, making it easy to access and damage underlying systems. If you're using Fides 2.11.0 to 2.19.0, update to version 2.19.0 or later to fix this issue.
What to do
- Update ethyca ethyca-fides to version 2.19.0.
- Update ethyca fides to version 2.19.0 or later.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| pip | ethyca | ethyca-fides |
>= 2.11.0, < 2.19.0 Fix: upgrade to 2.19.0
|
| – | ethyca | fides |
>= 2.11.0, < 2.19.0 cpe:2.3:a:ethyca:fides:*:*:*:*:*:*:*:* |
Original advisory text
Remote Code Execution in Custom Integration Upload in Fides
Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. The Fides webserver API allows custom integrations to be uploaded as a ZIP file. This ZIP file must contain YAML files, but Fides can be configured to also accept the inclusion of custom Python code in it. The custom code is executed in a restricted, sandboxed environment, but the sandbox can be bypassed to execute any arbitrary code. The vulnerability allows the execution of arbitrary code on the target system within the context of the webserver python process owner on the webserver container, which by default is `root`, and leverage that access to attack underlying infrastructure and integrated systems. This vulnerability affects Fides versions `2.11.0` through `2.19.0`. Exploitation is limited to API clients with the `CONNECTOR_TEMPLATE_REGISTER` authorization scope. In the Fides Admin UI this scope is restricted to highly privileged users, specifically root users and users with the owner role. Exploitation is only possible if the security configuration parameter `allow_custom_connector_functions` is enabled by the user deploying the Fides webserver container, either in `fides.toml` or by setting the env var `FIDES__SECURITY__ALLOW_CUSTOM_CONNECTOR_FUNCTIONS=True`. By default this configuration parameter is disabled. The vulnerability has been patched in Fides version `2.19.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. Users unable to upgrade should ensure that `allow_custom_connector_functions` in `fides.toml` and the `FIDES__SECURITY__ALLOW_CUSTOM_CONNECTOR_FUNCTIONS` are both either unset or explicit set to `False`.
References
- https://github.com/advisories/GHSA-p6p2-qq95-vq5h
- https://github.com/ethyca/fides/security/advisories/GHSA-p6p2-qq95-vq5h Vendor Advisory
- https://github.com/ethyca/fides/commit/5989b5fa744c8d8c340963b895a054883549358a Patch
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/41xxx/CVE-2023-41319... Vendor Advisory
- https://nvd.nist.gov/vuln/detail/CVE-2023-41319 Vendor Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Type
CWE-693Protection Mechanism Failure
CWE-94Code Injection
Timeline
Published6 Sep 2023
Updated3 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta