Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.8

CVE-2023-39270: GTKWave 3.3.115 can run code from crafted .lxt2 file

CVE-2023-39270 · published 2 years ago
Summary

GTKWave version 3.3.115 may run any program a user opens if they open a specially made .lxt2 file. The problem comes from a calculation error when the program reads the file’s layout information. Install the latest GTKWave update or avoid opening unknown .lxt2 files to stay safe.

What to do
  • Update debian gtkwave to version 3.3.118-0.1~deb12u1.
  • Update debian gtkwave to version 3.3.118-0.1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian gtkwave < 3.3.118-0.1~deb12u1
Fix: upgrade to 3.3.118-0.1~deb12u1
Debian:13 debian gtkwave < 3.3.118-0.1
Fix: upgrade to 3.3.118-0.1
Debian:14 debian gtkwave < 3.3.118-0.1
Fix: upgrade to 3.3.118-0.1
– tonybybell gtkwave 3.3.115
cpe:2.3:a:tonybybell:gtkwave:3.3.115:*:*:*:*:*:*:*
Ubuntu:16.04:LTS canonical gtkwave All versions
Original advisory text
Multiple integer overflow vulnerabilities exist in the LXT2 facgeometry parsing functionality of GTKWave 3.3.115. A specially crafted .lxt2 file can lead to arbitrary code execution. A victim would...
Multiple integer overflow vulnerabilities exist in the LXT2 facgeometry parsing functionality of GTKWave 3.3.115. A specially crafted .lxt2 file can lead to arbitrary code execution. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns the integer overflow when allocating the `rows` array.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
7.8 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-190Integer Overflow
Timeline
Published8 Jan 2024
Updated4 Nov 2026
First seen15 Sep 2026
Sources
CVE-2023-39270 · NVD
Track software like this
Free during beta