Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.5
CVE-2023-3649: Wireshark can crash from specially crafted iSCSI traffic
CVE-2023-3649 · published 3 years ago
Summary
Versions 4.0.0 through 4.0.6 of Wireshark may stop working if they receive a malformed iSCSI network packet or a capture file that contains one. This could make the application unavailable to users who need it for network analysis. Upgrade to a newer Wireshark version or apply any available patches to prevent the crash.
What to do
- Update debian wireshark to version 4.0.11-1~deb12u1.
- Update debian wireshark to version 4.0.7-1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Debian:12 | debian | wireshark |
< 4.0.11-1~deb12u1 Fix: upgrade to 4.0.11-1~deb12u1
|
| Debian:13 | debian | wireshark |
< 4.0.7-1 Fix: upgrade to 4.0.7-1
|
| Debian:14 | debian | wireshark |
< 4.0.7-1 Fix: upgrade to 4.0.7-1
|
| – | wireshark | wireshark |
>= 4.0.0, <= 4.0.6 cpe:2.3:a:wireshark:wireshark:*:*:*:*:*:*:*:* |
Original advisory text
Buffer Over-read in Wireshark
iSCSI dissector crash in Wireshark 4.0.0 to 4.0.6 allows denial of service via packet injection or crafted capture file
References
- https://security-tracker.debian.org/tracker/CVE-2023-3649 Vendor Advisory
- https://lists.debian.org/debian-lts-announce/2024/09/msg00049.html URL
- https://www.wireshark.org/security/wnpa-sec-2023-22.html URL
- https://gitlab.com/wireshark/wireshark/-/issues/19164 Third Party Advisory
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/3xxx/CVE-2023-3649.j... Vendor Advisory
- https://nvd.nist.gov/vuln/detail/CVE-2023-3649 Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Severity
5.5
Medium
Type
CWE-126Buffer Over-read
CWE-125Out-of-bounds Read
Timeline
Published14 Jul 2023
Updated4 Nov 2026
First seen15 Sep 2026
Track software like this
Free during beta