Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.9

CVE-2023-31485: debian/libgitlab-api-v4-perl may trust fake certificates

CVE-2023-31485 · published 3 years ago
Summary

The Perl library used to talk to GitLab (versions up to 0.26) does not check the authenticity of TLS certificates. An attacker who can intercept the network could pretend to be the GitLab server and read or modify data. Upgrade the library to a newer version or configure it to enforce proper certificate verification.

What to do
  • Update debian libgitlab-api-v4-perl to version 0.27-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian libgitlab-api-v4-perl All versions
Debian:13 debian libgitlab-api-v4-perl < 0.27-1
Fix: upgrade to 0.27-1
Debian:14 debian libgitlab-api-v4-perl < 0.27-1
Fix: upgrade to 0.27-1
– gitlab\ \ api\
cpe:2.3:a:gitlab\:\:api\:\:v4_project:gitlab\:\:api\:\:v4:*:*:*:*:*:*:*:*
Original advisory text
GitLab::API::v4 through 0.26 does not verify TLS certificates when connecting to a GitLab server, enabling machine-in-the-middle attacks.
GitLab::API::v4 through 0.26 does not verify TLS certificates when connecting to a GitLab server, enabling machine-in-the-middle attacks.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
5.9 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-295Improper Certificate Validation
Timeline
Published29 Apr 2023
Updated4 Nov 2026
First seen15 Sep 2026
Sources
CVE-2023-31485 · NVD
Track software like this
Free during beta