Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.7

CVE-2023-31223: Dradis before 4.8.0 allows persistent XSS by authenticated author users, related to avatars.

CVE-2023-31223 · published 3 years ago
Summary

Dradis before 4.8.0 allows persistent XSS by authenticated author users, related to avatars.

What to do
  • Update dradisframework dradis to version 4.8.0 or later.
Affected software
VendorProductAffected versions
dradisframework dradis < 4.8.0
cpe:2.3:a:dradisframework:dradis:*:*:*:*:*:*:*:*
Original advisory text
Dradis before 4.8.0 allows persistent XSS by authenticated author users, related to avatars.
Dradis before 4.8.0 allows persistent XSS by authenticated author users, related to avatars.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
8.7 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published25 Apr 2023
Updated4 Nov 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta